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1 Licensing
A license enables a server, either a physical server or a virtual machine, to be deployed and managed by
the Altiris Deployment Server. One license is required for each server being managed. After a license is
applied to a specific server, the license cannot be removed or transferred to another server.
A license file contains licenses for a predetermined number of servers. License files are not Rapid Deployment
Pack version-specific.
To view the number of licensed nodes from the console, click Help>About.

License types
• Purchased license. To obtain this license file, first follow the instructions on your license entitlement

certificate to get your license registration number, then access http://www.hp.com/servers/rdp/register.

• 10-node, 30-day evaluation license. To obtain this license file, access
http://www.hp.com/servers/rdp/eval.

• 10-node, 7-day evaluation license. This license is built into the Deployment Server.

Applying a license file
Applying a license file during an first-time installation or upgrade

To select the appropriate licensing option, see Chapter 3 Installing.

Adding a license file to an existing installation
1. Shut down all Deployment Server Consoles and Deployment Server Web Consoles.
2. Click Start>Programs>Altiris>Deployment Solution>Product Licensing Utility.
3. Enter the path to the new license file in the Activation Key File Information field, and click Next.
4. Follow the instructions to apply your additional licenses.

Replacing licenses in an existing installation
If you have combined or transferred licenses and have obtained a new license file, to replace your existing
license file follow the steps above for adding a license file. On the third wizard step, select Replace all
existing license Activation Keys with this new Activation Key.

License types 7
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2 Prerequisites
Network infrastructure requirements

If Preboot eXecution Environment (PXE) is used to perform remote deployment of servers, then Dynamic Host
Configuration Protocol (DHCP) must be installed and accessible on the network before the installation.

Deployment Server requirements
• Hardware:

For a new install, a HP ProLiant server with at least a 2.0 GHz processor and 1 GB RAM or an
equivalent virtual machine

•

• The correct date and time

• Microsoft® Windows® operating system:

• Microsoft Windows Server™ 2003 x86 (SP1, R2, SP2) Standard or Enterprise Editions

NOTE: The server must not be a domain controller.

• Available disk space:

2 GB for the base installation•

• 1 GB for each Windows distribution

• 1 GB for each VMware ESX distribution

• 4 GB for each Linux distribution

• Additional space for captured disk images

• A network connection configured with a static IP address

NOTE: Changing the IP address configuration after installation is difficult, therefore, set the appropriate
IP address before beginning the install.

• To use the Deployment Server Web Console, IIS with ASP.NET must be installed.

• To deploy VMware ESX or Linux, an FTP server must be installed. For information on installing Microsoft
IIS FTP server, see Appendix C Installing an IIS FTP server.

For more information about requirements for the Deployment Server, see the Altiris Deployment Solution
Deployment and Migration Guide at http://www.hp.com/servers/rdp.

Network infrastructure requirements 9
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3 Installing
Getting started

• Log into the local console. The Rapid Deployment Pack cannot be installed through Terminal Services,
remote shell, or from a network share.

• Obtain a license file (either purchased or evaluation).

• Collect the applicable Windows, VMware ESX, or Linux distribution files.

• Get the applicable Windows product keys.

Before you upgrade
• If you have modified any provided jobs or batch files, make backup copies.

• Shut down all Deployment Server Consoles and Web Consoles.

• When upgrading from Rapid Deployment Pack 3.00 – 3.70, the WinPE 1.6 PXE images will be replaced
with WinPE 2.1 PXE images and the WinPE 1.6 Boot Disk Creator HP drivers and support files will be
removed. WinPE 1.6 is no longer supported.

Installing
1. On the intended Deployment Server, access the Rapid Deployment Pack autorun utility using one of the

following methods:

• Insert the physical DVD into the DVD drive.

• Extract the ISO image.

• Mount the ISO image.

2. Read the terms of the ProLiant Essentials End User License Agreement (EULA), and click Agree to accept
the terms.

3. On the Overview screen, click Next.
4. On the Pre-Installation screen, click Next.
5. Verify that the appropriate components are selected for installation, and click Install. If you plan to use

an existing database, clear the Microsoft SQL Server 2005 Express option.
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6. If selected, the Microsoft .NET Frameworks and Microsoft SQL Server will be installed silently. The
Microsoft WAIK 2.1, also known as the “Automated Installation Kit (AIK) for Windows Vista SP1 and
Windows Server 2008”, must be manually downloaded and installed. It is available at http://
www.microsoft.com/downloads/
details.aspx?familyid=94bb6e34-d890-4932-81a5-5b50c657de08&displaylang=en&tm. After completing
the WAIK install, reinsert the Rapid Deployment Pack media before clicking Continue.

7. If the Altiris Deployment Server was not selected for installation, proceed to step Step 23.
8. Read the Altiris EULA, and click Yes.
9. If the server has multiple network adapters, select the appropriate interface for the Deployment Server,

and click Select IP.
10. Select the appropriate licensing option, and click Next.

• If installing for the first-time, select Free 7 day license, or select License file, and enter the license
file path and name.

• If upgrading, verify that Upgrade using existing license is selected.

NOTE: When upgrading, you must select Upgrade using existing license to avoid losing
existing licenses.
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11. Enter the service credentials for the Deployment Server, and click Next.

NOTE: Do not install the Deployment Server component to a remote server because it will cause the
Integration Module installations to fail.

12. Select the name of the server instance where you want to install the database, and click Next. If the
database is located on a remote server, you might be prompted for credentials. Enter a username and
password with administrative rights.
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13. Enter the appropriate database authentication method, and click Next.

NOTE: Choosing SQL Server Authentication will cause some of the Integration Module Configuration
tasks to fail.

14. If upgrading, click Yes when prompted to retain the data in the existing database.
15. On the Pre-boot Operating Systems screen, click Next.

NOTE: Even though the WinPE options are not selected, they will be installed.
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16. Specify the location where PXE Server is to be installed, and click Next. If DHCP is installed on a
separate server, click OK when prompted that DHCP services are required. If you choose not to use
PXE, then see Appendix D Creating and using automation boot media.

NOTE: When upgrading, you must select No. While unintuitive, this option will actually cause all of
the PXE servers to upgrade correctly.

17. Specify how clients connect to the Deployment Server, and click Next.
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18. Specify the location where the Deployment Server Console is to be installed, and click Next.

NOTE: Do not install the initial Deployment Console component to a remote server because it causes
the Integration Module installations to fail.

19. Specify where the Deployment Server Web Console is to be installed, and click Next.
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20. On the Installation Information screen, click Install.

21. If upgrading, click Yes when prompted to replace the eXpress share.
22. When the installation is complete, click Finish.
23. If ProLiant Integration Module software was not selected, proceed to step Step 34.
24. On the Prerequisites screen, click Verify. When the process is complete, click Next.
25. Select the operating systems that are to be deployed to target servers, and click Next.
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26. Specify the appropriate configuration options, and click Next. For more information, see Appendix B
Manually modifying configuration settings.

NOTE: The MAC Address lookup value is requried for Integrity servers and new HP ProLiant servers.

27. Specify the appropriate Windows product keys, and click Next.
28. On the Installation and Configuration screen, click Install.
29. If upgrading, click OK when prompted to back up and overwrite existing configuration files, and reimport

existing jobs.
30. For each operating system that was selected and is not present, specify the root directory of the distribution

files, and click Copy. If you choose to skip copying any distribution, see Appendix A Manually installing
distribution files.

31. If prompted to reinsert the Rapid Deployment Pack media, reinsert it, and click OK.
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32. If you skipped any distributions, click OK when the warning message appears.
33. On the Installation and Configuration screen, click Finish.
34. If Integrity Integration Module software was not selected, proceed to step Step 46.
35. On the Prerequisites screen, click Verify, when the verification process is complete, click Next.
36. Select the operating systems that are to be deployed to target servers, and click Next.

37. Specify the appropriate configuration options, and click Next. For more information, see Appendix B
Manually modifying configuration settings.

NOTE: The MAC Address lookup value is requried for Integrity servers and new HP ProLiant Servers.

38. Specify the appropriate Windows product keys, and click Next.
39. On the Installation and Configuration screen, click Install.
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40. If upgrading, click OK when prompted to back up and overwrite existing configuration files and reimport
existing jobs.

41. For each operating system that was selected and is not present, specify the root directory of the distribution
files, and click Copy. If you choose to skip copying any distribution, see Appendix A Manually installing
distribution files.

42. If prompted to reinsert the Rapid Deployment Pack media, reinsert it, and click OK.
43. If you skipped any distribution, click OK when the warning message appears.
44. On the Installation and Configuration screen, click Finish.
45. On the Installation screen, click Next.
46. On the Post-Installation screen, click Finish.
47. Click Yes when prompted to reboot the server.
The installation is complete.
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4 Configuring

IMPORTANT: By default, the Create Disk Image and Distribute Disk Image tasks operate on the “first”
disk. The disks are enumerated using a proprietary algorithm. The “first” disk might not be the system boot
disk. The Altiris showdisk utility can be used to generate human-readable disk enumeration output. This utility
is called in the provided Read Hardware Configuration jobs. For more information on reading the showdisk
output, see the Rapid Deployment Pack Knowledge Base at http://www.hp.com/servers/rdp/kb.

Configuring scripted installs
The scripted install jobs use a small image to partition and format the disk. When deploying to a server with
multiple disks, either DAS or SAN, you might have to specify the system boot disk in the job for the NTFS.img
or GRUB.img images.
To specify a particular disk:
1. In the Deployment Server Console, copy, rename, and edit the job.
2. Modify the Distribute Disk Image task.
3. In the Additional Parameters box, add the -dx switch, where x is an integer that represents the

appropriate disk number.
Additionally, for Red Hat Linux in a multiple disk configuration, the kickstart file must specify the system boot
disk.
1. On the Deployment Server, copy and rename the kickstart file.
2. Modify the new kickstart file by replacing the autopart command with separate part command lines

and adding the --ondisk=XXX option to each where XXX is the device label.
Example for non-LVM:
part /boot --size=75 --ondisk=cciss/c0d0part swap –size=1000
--ondisk=cciss/c0d0part / --size 5120 -–grow --ondisk=cciss/c0d0

Example for LVM:
part /boot --size=100 --fstype=ext3 --ondisk=cciss/c0d0part pv.01 --size=100
--grow --ondisk=cciss/c0d0volgroup VolGroup00 -–pesize=32768 pv.01

3. Edit the Run Script – Create Boot Environment task in the job created above to use the new kickstart
file created in step 2.

Configuring SAN-attached scripted install
In addition to the steps in the Configuring-scripted-installs section, some further steps might be necessary.
For VMware ESX Server 3.x, disconnect the SAN. After the operating system install is complete, reconnect
the SAN and create a VMFS datastore on it.

Configuring image installs
When capturing or deploying an image to a server with multiple disks, either DAS or SAN, you might have
to specify the system boot disk in the job.
To specify a particular disk:
1. In the Deployment Server Console, copy, rename, and edit the job.
2. Modify the Create Disk Image or Distribute Disk Image task.
3. In the Additional Parameters box, add the -dx switch, where x is an integer that represents the

appropriate disk number.
When deploying Linux with LVM, x must be a comma-separated list of integers representing all of the disk
numbers that the LVM volume will span. For example, to deploy an LVM image that spans the first three
disks, use -d1,2,3.

Configuring scripted installs 21
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Configuring HP BladeSystem enclosures
The console display name for a new server blade is a combination of the rack name, enclosure name, and
bay number. Before you connect the first blade in an enclosure to the Deployment Server, assign unique
names to the rack and enclosure to prevent conflicting database entries.
To change the rack and enclosure names, follow the procedure specific to each server type:

• HP BladeSystem c-Class servers—Access the Onboard Administrator and change the rack name and
the enclosure name. See the server documentation for complete details.

• ProLiant BL p-Class servers—Place at least one server blade in each enclosure, and before powering
up the server blade, change the rack and enclosure information using the Integrated Lights-Out (iLO)
interface. See the server documentation for complete details.

If the rack and enclosure names are changed after the blades have appeared in the console, then the blades
must be rebooted for the new rack and enclosure names to be discovered and the original rack and enclosure
names must be manually deleted from the Physical Devices View in the console.

Virtual Machine Deployment Support
Deployment to virtual machines requires manual intervention. Refer to the Rapid Deployment Pack Knowledge
Base “Virtual Machine Deployment Support”, Article #193, at http://www.hp.com/servers/rdp/kb.
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5 Understanding the Deployment Server
The Rapid Deployment Pack populates the Deployment Server Console with jobs and the Deployment Server
directory with tools, scripts, configuration files, software drivers, and documentation files. This section explains
these provided jobs and files, and the directory structure.

Jobs
The Rapid Deployment Pack adds three root folders into the Jobs pane.

Table 5-1 Job folders

DescriptionFolder

The jobs in this folder perform a complete server deployment. They deploy a default hardware
configuration, execute a scripted operating system installation, and install the appropriate ProLiant
or Integrity Support Pack.

Server Deployment

The jobs in this folder provide more granular control over the server deployment process. By providing
jobs that perform only hardware configuration, operating system installation, and value-add software
installation, you can easily combine various jobs together to suit your needs.

Server Deployment Toolbox

The jobs in this folder perform a complete server deployment. They deploy a default hardware
configuration and a captured disk image.

Server Imaging

NOTE: When performing Linux imaging or non-sysprep Windows imaging, the reference server and the
target server must have an identical hardware configuration.
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Job default settings
Unless otherwise indicated in the job name, the job uses the following default settings.
Table 5-2 Hardware configuration default settings

Default settingComponent

Factory defaultsSystem ROM

RAID level based on the number of attached drivesSmart Array

Not configured in the standard jobsiLO

Not configured in the standard jobsSAN HBA

Table 5-3 Windows default settings

Default settingComponent

The administrator password is password. This password is stored as clear text in the
unattend answer file. HP recommends changing the default administrator password.

Windows administrator password

A single partition is created automatically that expands to the full drive size.Drive configuration

The Windows computer name uses the 15 right-most characters of the console display
name.

Computer name

Firewall settings are disabledFirewall

Table 5-4 VMware default settings

Default settingComponent

The root password is password. This password is stored as clear text in the kickstart
file. HP recommends changing the default root password.

VMware root password

When configuring the disk partition for a scripted operating system installation, various
VMware ESX Server specific partitions are created. These are the default settings and
must not be changed.

Drive configuration

The VMware ESX Server host name uses the console display name.Host name

VMware ESX Server specific packages are installed. Do not change this setting.Packages

Firewall settings are enabled with only some ports open.Firewall

Table 5-5 Linux default settings

Default settingComponent

The root password is password. This password is stored as clear text in the
kickstart/control file. HP recommends changing the default root password.

Linux root password

The disk space is partitioned according to Red Hat or SUSE default specifications. Red
Hat Enterprise Linux installs Logical Volume Manager (LVM) by default.

Drive configuration

The Linux host name uses the console display.Host name

Basic Linux server packages are installed.Packages

Firewall settings are disabled.Firewall
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Table 5-6 Default Read /Capture and Write/Deploy jobs

FilenameRead(Capture)/Write Job Pair

Server Deployment Toolbox > 1 – Hardware Configuration

.\lib\hwconfig\system\pl-capture.xmlProLiant ML/DL/BL System Configuration

.\lib\hwconfig\array\pl-capture.iniProLiant ML/DL/BL Array Configuration

.\lib\hwconfig\hba\ID.ini where ID is the console computerProLiant ML/DL/BL HBA Configuration
[server specific]

.\lib\hwconfig\system\i-capture.xmlIntegrity RX/BL System Configuration

.\lib\hwconfig\array\i-capture.iniIntegrity RX/BL Array Configuration

Server Deployment Toolbox > 2A – OS Installation (Imaged)

.\lib\images\capture-windows.imgWindows Image

.\lib\images\capture-linux.imgLinux Image

Server Deployment Toolbox > 2C – OS Installation (SysPrep)

.\lib\images\xxxx-sysprep.img where xxxx is the operating system shortcut nameWindows xxxx Sysprep Image

Server Imaging

\lib\images\yyyy-linux.img
where yyyy is the computer model name, for example ProLiant DL360 G4.

Linux Image

.\lib\images\xxxx-sysprep.img where xxxx is the operating system shortcut nameWindows xxxx Sysprep Image

Directory structure
The following table provides an overview of the Deployment Server directory as populated by the Rapid
Deployment Pack. The ‘.’ in the directory paths below represents the Deployment Server installation directory.
Table 5-7 Deployment Server directory structure

Directory contentsDirectory

Rapid Deployment Pack documentation.\docs

The .bin files for the provided jobs.\jobs

Windows SmartStart Scripting Toolkit , Linux SmartStart Scripting Toolkit , and various tools and
scripts

.\lib\bin32

Various tools and scripts.\lib\bin64

Smart Setup Scripting Toolkit for Integrity, and various tools and scripts.\lib\binia64

Presupplied and captured hardware configuration files.\lib\hwconfig

Presupplied and captured image files.\lib\images

Operating system scripted install answer files separated into subdirectories per OS.\lib\osconfig

Operating system distribution files separated into subdirectories per OS.\lib\osdist

ProLiant Drivers for Windows, Integrity Drivers for Windows, and Altiris Deployment Agents
The driver subdirectories are either a specific version number, such as 770 or ZZZ which is a copy
of the latest version subfolder. The ZZZ subfolder is used by the provided jobs.

.\lib\osoem

Operating system sysprep imaging answer files separated into subdirectories per OS..\lib\ossysprep

ProLiant Support Packs, ProLiant Firmware Maintenance, and Integrity Support Packs
The support pack subdirectories are either a specific version number such as 7.70 or Z.ZZ which
is a copy of the latest version subfolder. The Z.ZZ subfolder is used by the provided jobs.

.\lib\software

NOTE: If editing ESX or Linux files on the Deployment Server, use a text editor that saves the file in Linux
compatible format without adding extra characters.
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Job—Directory relationship
The provided jobs follow a common design consisting of a sequence of Run Script, image capture or deploy,
and reboot tasks. Most important of these are the Run Script tasks. The embedded script in the Run Script
tasks, reference files or directories using environment variables and then pass those variables to external
wrapper scripts. The wrapper scripts perform one well-defined function, for example, calling a single utility
like conrep. Using external scripts enables detailed error reporting to the Deployment Server.
It should only be necessary to edit the embedded Run Script code, for example to reference a different file
or directory. However, be aware that the wrapper scripts do not accept arbitrary file paths. They are
hard-coded to specific locations in the .\lib tree.
The following table shows a condensed listing of the Deploy ProLiant ML/DL/BL + Windows 2003 x64
Enterprise + PSP job. The bold lines represent each task in the job. Each task is followed by its contents, for
example for Run Script tasks; this is the embedded script code. Additionally, the indented lines represent
code called by the embedded Run Script code.
Table 5-8 Deploy ProLiant ML/DL/BL + Windows 2003 x64 Enterprise + PSP job

Run Script Deploy System Configuration {WinPE Managed (32-bit)}

set inputfile=pl.xml

call f:\lib\bin32\winpe\conrep.cmd –l %inputfile%

f:\lib\bin32\winpe\conrep.exe –l –ff:\lib\hwconfig\system\pl.xml

Power Control (Reboot)

Run Script Deploy Array Configuration {WinPE Managed (32-bit)}

set inputfile=pl-acu-rd.ini

call f:\lib\bin32\winpe\acu.cmd -i %inputfile% -internal -reset

f:\lib\bin32\winpe\acu\hpacubin.exe -i f:\lib\hwconfig\array\pl-acu-rd.ini –internal -reset

Power Control (Reboot)

Run Script Deploy System Configuration {WinPE Managed (32-bit)}

set inputfile=pl-win.xml

call f:\lib\bin32\winpe\conrep.cmd –l %inputfile%

f:\lib\bin32\winpe\conrep.exe –l –ff:\lib\hwconfig\system\pl.xml

Distribute Disk Image {WinPE Managed (32-bit)}

f:\lib\images\ntfs.img

Run Script Copy ProLiant Files {WinPE Manged (64-bit)}

set oem=proliant.zzz\w52

call f:\lib\bin64\winpe\osoem1.cmd

copy f:\lib\osoem\proliant.zzz\w52\*.* c:\

Run Script Copy Altiris Files {WinPE Manged (64-bit)}

rem replacetokens .\lib\osoem\altiris\aclient.txt .\lib\osoem\altiris\%ID%.tmp

set configfile=%ID%.inp

call f:\lib\bin64\winpe\osoem2.cmd

copy f:\lib\osoem\altiris\%ID%.inp c:\$oem$\aclient\aclient.inp

copy f:\lib\osoem\altiris\altiris-aclient*.exe c:\$oem$\aclient\aclient.exe

Run Script Copy Unatted.txt {WinPE Manged (64-bit)}

rem replacetokens .\lib\osconfig\w52e.64\default.txt .\lib\osoem\w52e.64\%ID%.txt

set unattendfile=w52e.64\%ID%.txt

call f:\lib\bin64\winpe\osconfig1.cmd
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Run Script Deploy System Configuration {WinPE Managed (32-bit)}

copy f:\lib\osoem\w52e.64\%ID%.txt c:\unattend.txt

Run Script Copy Distribution Files {WinPE Manged (64-bit)}

set dist=w52e

call f:\lib\bin64\winpe\osdist1.cmd

copy f:\lib\osdist\w52e\i386\*.* c:\i386

copy f:\lib\osdist\w52e\amd64\*.* c:\amd64

Run Script Start Install {WinPE Manged (64-bit)}

c:\amd64\winnt32.exe /s:c:\amd64 /unattend:c:\unattend.txt

Install Package

f:\lib\software\ProLiant Support Pack Z.ZZ for Windows 2003 x64\hpsum.exe –silent

Power Control (Reboot)
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Automation environments
An “automation environment” is an operating system in which scripts can be run on the target independent
of the target’s production operating system or the Deployment Server’s operating system. The target can
boot the automation environment either from a CD-ROM, USB key, or through PXE. Each automation
environment consists of the necessary base files, additional HP drivers, and the appropriate Altiris Deployment
Agent.
The Run Script, Create Disk Image, and Distribute Disk Image tasks enable the user to specify which automation
environment to run in. The Rapid Deployment Pack jobs specify a specific automation environment to avoid
ambiguity and to ensure that the utilities run in the correct and tested environment.
The following illustration and table provide a view of how the Deploy ProLiant ML/DL/BL + Windows
2003 x64 Enterprise + PSP scripted install job uses the various automation environments.

Table 5-9 State Transitions

DescriptionTransition

Power up a bare-metal target server. Since the target does not have a bootable hard drive, it PXE
boots. The PXE Server sends it the default Linux Managed (Auto-Select) image. Once the image is
loaded, the agent connects to the Deployment Server. Since this is the initial connection and no
pending job exists, the Deployment Server directs the agent to wait.

1

Schedule the Deploy ProLiant ML/DL/BL + Windows 2003 x64 Enterprise + PSP job on the
target. The Deployment Server determines that the target is in the incorrect automation environment.
It directs the agent to set the one-time boot EV to PXE and then reboot. When the target PXE boots,
the PXE Server sends it the WinPE Managed 32-bit image. Once the image is loaded, the agent
connects to the Deployment Server and begins to execute task 1.

2

Task 2 in the job is a Reboot. The Deployment Server directs the agent to set the one-time boot EV
to PXE and then reboot. When the target PXE boots, the PXE Server sends it the WinPE Managed
32-bit image. Once the image is loaded, the agent connects to the Deployment Server and executes
task 3.

3

Task 4 in the job is a Reboot. The Deployment Server directs the agent to set the one-time boot EV
to PXE and then reboot. When the target PXE boots, the PXE Server sends it the WinPE Managed
32-bit image. Once the image is loaded, the agent connects to the Deployment Server and executes
tasks 5 and 6.

4

Task 7 in the job runs under a different automation environments. The Deployment Server directs
the agent to set the one-time boot EV to PXE and then reboot. When the target PXE boots, the PXE
Server sends it the WinPE Managed 64-bit image. Once the image is loaded, the agent connects
to the Deployment Server and executes tasks 8 thru 12.

5

Task 12 starts the Windows installation process. It performs the first part of setup and reboots the
target. Now that the target has a bootable hard drive, the Window setup kernel boots and completes
the install. As part of the install, the Deployment Agent for Windows gets installed. While the
Windows installation process is in progress, the Deployment Server is waiting for the agent to get
installed and connected. Once the agent connects to the Deployment Server, it executes task 13.

6

The last task in the job is a Reboot. The Deployment Server directs the agent to reboot.7
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6 Using the Rapid Deployment Pack
Console basics

Computers Pane—This pane shows the managed computers. The New Computers group shows computers
that have connected to the Deployment Server for the first time using the automation environment agent.
Click View>Show Physical Devices to add the Physical Devices group.
Jobs Pane—This pane shows the provided jobs.
Executing a job is a simple as dragging-and-dropping one or more computers onto a job, or vice-versa.
Details Pane—The right-hand side of the console displays information about the currently selected computer
or job. For a computer, basic properties and job history are displayed. For a job, tasks and computer history
are displayed.
Double-clicking an item in the job history or computer history, brings up the Job Schedule Information
dialog. This dialog shows the status of each task in the schedule. Clicking Status Details brings up the
Schedule Status Detail dialog, which displays detailed return codes and status messages.
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Connecting server blades
1. Connect the enclosure to the network that contains your Deployment Server, and power up the enclosure.
2. Insert the server blades into the enclosure, but do not power up the server blades.
3. Change the default rack and enclosure names.
4. Power up the server blades.
5. From the Computer pane, right click on a server blade and select Power Control>iLO – Interface.

This action accesses the iLO homepage, from which you can bring up the remote console and watch
what is happening on the server blade.

Deploying the first server blade
1. In the Jobs pane, in the Server Deployment folder, select a Windows scripted install job. Drag the job

onto the server blade in the Computers pane.

2. Select Run this job immediately, and click OK.
3. Double-click the computer in the job’s computer history to view the progress of the job.

Reconfiguring the server blade
By default the Windows scripted install job will configure the computer name as the console display name
and network as DHCP. This is probably not sufficient for a server. To reconfigure the server:
1. In the Computers pane, right-click on the blade and click Configure.
2. Click Microsoft Networking , and enter a new computer name and a new workgroup or domain

name.
3. Click TCP/IP, and enter the appropriate IP information.
4. Click OK.
5. Select Run this job immediately, and click OK.
6. If the Windows scripted install job is still running, click OK when the warning message appears.
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Next steps
Now that you have seen how easy it easy to deploy an operating system to a server, you will need to:

• Learn how to adapt and customize the Rapid Deployment Pack for your environment. The provided
jobs and files are generic and will work out of the box; however, they are probably not sufficient for
a complex server environment. For example, you might want to change the default password in the
various unattend and kickstart files.

• Define roles, processes, and best practices. Spending some upfront time detailing people and processes
will enable you to take full advantage of the Rapid Deployment Pack as a powerful tool for simplifying
server deployment.
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7 HP support and contact information
Online resources

• Information about the Rapid Deployment Pack and the latest updates are available from the HP ProLiant
Essentials Rapid Deployment Pack website at http://www.hp.com/servers/rdp.

• Regularly updated troubleshooting information, frequently asked questions, and specific how-to
procedures are available at the HP ProLiant Essentials Rapid Deployment Pack Knowledge Base at
http://www.hp.com/servers/rdp/kb.

• Problem-solving information and ideas from other IT professionals are available in the IT Resource
Center (ITRC) User Forum “ProLiant Deployment & Provisioning.” You can access this forum from the
Management Software and System Tools link at http://forums.itrc.hp.com.

• Information and resources about the Altiris Deployment Solution are available from the Altiris website
at http://www.altiris.com.

HP contact information
For the name of the nearest HP authorized reseller:

• In the United States, see the HP U.S. service locator webpage at http://www.hp.com/service_locator.

• In other locations, see the Contact HP worldwide webpage at
http://welcome.hp.com/country/us/en/wwcontact.html.

For HP technical support:

• In the United States, for contact options see the Contact HP United States webpage at
http://welcome.hp.com/country/us/en/contact_us.html. To contact HP by phone: Call 1-800-HP-INVENT
(1-800-474-6836). This service is available 24 hours a day, 7 days a week. For continuous quality
improvement, calls may be recorded or monitored. For U.S. customers, say "Insight Manager" when
prompted for the product name.

• In other locations, see the Contact HP worldwide webpage at
http://welcome.hp.com/country/us/en/wwcontact.html.

HP Software Technical Support and Update Service
HP offers a number of software support services, many of which are provided to our customers at no additional
charge.
Software Technical Support and Update Service - Insight Control suites and select ProLiant Essentials software
products include one year of 24 x 7 HP Software Technical Support and Update Service. This service provides
access to HP technical resources for assistance in resolving software implementation or operations problems.
The service also provides access to software updates and reference manuals either in electronic form or on
physical media as they are made available from HP. (Customers who purchase an electronic license to use
are eligible for electronic updates only.) With this service, Insight Control and ProLiant Essentials customers
will benefit from expedited problem resolution as well as proactive notification and delivery of software
updates. For more information about this service, see http://www.hp.com/services/insight.
Registration for Software Technical Support and Update Service:
There are two methods for registering:

• If you received a license entitlement certificate, automated registration for this service will take place
upon online redemption of the license certificate/key.

• If the license information you received for your product instructs you to register for Software Technical
Support and Update Service, follow the instructions so that you will be eligible for telephone support
and product updates.

How to Use Your Software Technical Support and Update Service:
Once registered, you will receive a service contract in the mail containing the Customer Service phone
number and your Service Agreement Identifier (SAID). You will need your SAID when calling for technical
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support. Using your SAID, you can also go to the Software Update Manager (SUM) web page to view your
contract online and elect electronic delivery for product updates.
Warranty – HP will replace defective delivery media for a period of 90 days from the date of purchase.
This warranty applies to all Insight Control Management, HP Systems Insight Manager, and ProLiant Essentials
products.
Join the discussion – The HP Support Forum is a community-based, user-supported tool for HP customers to
participate in discussions amongst the customer community about HP products. For discussions related to
Insight Control and ProLiant Essentials software, see the "Management Software and System Tools" area.
Software and Drivers download pages – provides latest software and drivers for your ProLiant products.
Management Security (http://www.hp.com/servers/manage/security) – HP is proactive in its approach to
the quality and security of all its management software. Be sure to check this website often for the latest
down loadable security updates.
Obtain the latest SmartStart Release (http://www.hp.com/servers/smartstart) – The SmartStart, Management,
and Firmware CDs are now freely available for download following a simple registration from the SmartStart
web site. If you wish to receive physical kits with each release, you can order single release kits from the
SmartStart web site. To receive proactive notification when SmartStart releases are available, subscribe to
Subscriber's Choice at http://www.hp.com/go/subscriberschoice.
HP Worldwide Customer Service contact numbers are available at
http://www.hp.com/country/us/en/wwcontact.html. For U.S. customers, say "Insight Manager" when
prompted for the product name.
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A Manually installing distribution files
If you did not copy the Windows, ESX, or Linux distribution files during the installation, you must manually
copy the files for the scripted install jobs to function properly. Manually copying the distribution files produces
the same results as copying the files during the installation.
To manually copy the distribution files, copy the entire contents of each distribution CD or DVD to the
appropriate .\lib\osdist\yyyy directory, where yyyy indicates the operating system shortcut name.

Table A-1 Operating system directory names

Directory nameOperating system

w52eWindows 2003 - Enterprise Edition

w52sWindows 2003 - Standard Edition

w52wWindows 2003 - Web Edition

w52e.64Windows 2003 x64 - Enterprise Edition

w52s.64Windows 2003 x64 - Standard Edition

w52e.ia64Windows 2003 IA64 - Enterprise Edition

w61Windows 2008

w61.64Windows 2008 x64

w61.ia64Windows 2008 IA64

vmesx302VMware ESX Server 3.0.2

vmesx350VMware ESX Server 3.5.0

rhas46Red Hat Enterprise Linux AS 4.6 for x86

rhes46Red Hat Enterprise Linux ES 4.6 for x86

rhas46.64Red Hat Enterprise Linux AS 4.6 for AMD64 and Intel® EM64T

rhes46.64Red Hat Enterprise Linux ES 4.6 for AMD64 and Intel EM64T

rhas46.ia64Red Hat Enterprise Linux AS 4.6 for Intel Integrity

rhes46.ia64Red Hat Enterprise Linux ES 4.6 for Intel Integrity

rhel51Red Hat Enterprise Linux 5.1 for x86

rhel51.64Red Hat Enterprise Linux 5.1 for AMD64 and Intel EM64T

rhel51.ia64Red Hat Enterprise Linux 5.1 for Intel Integrity

sles10sp1SUSE Linux Enterprise Server 10 Service Pack 1 for x86

sles10sp1.64SUSE Linux Enterprise Server 10 Service Pack 1 for AMD64 and
Intel EM64T

sles10sp1.ia64SUSE Linux Enterprise Server 10 Service Pack 1 for Intel Integrity
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B Manually modifying configuration settings
Synchronize display names with computer names option

The Deployment Server can use a console display name that is different from the actual computer name.
However, the console can always reflect the same name as the computer name.
To manually enable synchronization of the display and computer names:
1. In the Deployment Server Console, click Tools>Options.
2. Click the Global tab.
3. Select the Synchronize display names with computer names.
4. Click OK.

Primary lookup key option
The Deployment Server uses the primary lookup key to determine if a server is already in the database. HP
recommends setting the primary lookup key as the server serial number and MAC address.
To manually set the primary lookup key to serial number and MAC address:
1. In the Deployment Server Console, click Tools>Options.
2. Click the Global tab.
3. Select Serial Number and MAC Address as the Primary lookup keys.
4. Click OK.

PXE initial deploy boot timeout option
By default, when a new computer (a computer not listed in the Deployment Server database) performs a PXE
boot, the PXE server sends the computer the PXE menu and waits for manual selection of the Initial Deployment
option. This process is not practical for servers, especially server blades with no local keyboard, mouse, or
monitor.
To manually change the Initial Deploy boot option:
1. In the Deployment Server Console, click Tools>PXE Configuration.
2. Click the DS tab.
3. Select Enable response to request from computers not in the DS Database.
4. Select Wait for Boot Menu default timeout before continuing with the PXE process.
5. Click Save, and then click OK.

Client/server file transfer port option
For adlagent to properly transfer files under VMware ESX 3.x, the client/server file transfer port must be set
to match the value in the supplied ESX kickstart files.
To manually set the client/server file transfer port to 4300:
1. In the Deployment Server Console, click Tools>Options.
2. Click the Global tab.
3. Select Client/server file transfer port, and enter 4300.
4. Click OK.

Creating an IIS FTP virtual directory option
For VMware ESX and Linux scripted installation deployments, a virtual directory must be configured on an
FTP server, such as IIS.
If you use an FTP server other than IIS, use the same entry settings.
To manually configure IIS FTP:
1. Launch the Internet Information Services (IIS) Manager.
2. Expand the directory in the left pane, and select Default FTP Site or another existing FTP site.
3. Right-click the FTP site, and click New>Virtual Directory.
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4. Complete the Virtual Directory wizard, entering the following information when prompted.
Table B-1 Virtual directory information

EntryField

DSLIBVirtual Directory Alias

<Altiris Installation Directory>\libFTP Site Content Directory

ReadVirtual Directory Access Permissions

5. Right-click the FTP site, and click Properties.
6. Click the Security Accounts tab.
7. Select Allow Anonymous Connections, and click OK.
8. If the FTP site name is followed by “(Stopped),” right-click the site name, and click Start.

Windows product keys
For Windows scripted installation deployments, a Windows product key must be provided.
To manually configure the Windows product keys:
1. In the Deployment Server Console, click Tools>Integration Module>User Tokens Editor.
2. Add or edit the appropriate entry.
3. Click the Save button.
Table B-2 User Tokens table entries

Token nameOperating system

w52productkeyWindows 2003 x86

w52.64productkeyWindows 2003 x64

w52.ia64productkeyWindows 2003 IA64

w61dcproductkeyWindows 2008 x86 Datacenter

w61eproductkeyWindows 2008 x86 Enterprise

w61sproductkeyWindows 2008 x86 Standard

w61dc.64productkeyWindows 2008 x64 Datacenter

w61e.64productkeyWindows 2008 x64 Enterprise

w61s.64productkeyWindows 2008 x64 Standard

w61.ia64productkeyWindows 2008 IA64 Standard
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C Installing an IIS FTP server
To install an IIS FTP server:
1. Log in to the Deployment Server as a user with administrator rights.
2. Click Start>Control Panel>Add/Remove Programs.
3. Click Add/Remove Windows Components.
4. Select Application Server, and click Details.
5. Select Internet Information Services (IIS), and click Details.
6. Select File Transfer Protocol (FTP) Server, and click OK.
7. Click OK again.
8. Click Next.
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D Creating and using automation boot media
If you choose not to use PXE in your deployment infrastructure, you must create automation boot media for
each automation environment that you will be using. The boot media boots a target server to automation
without leaving any files on the server, and can be installed to DVDs, CDs, or USB keys. Using the Boot Disk
Creator utility to create boot media is a straightforward process. However, remember:

• On the Create Configuration step, from the OEM Extensions dropdown, select <all> to include the
latest HP drivers.

• On the Network Adapters step, for WinPE select Auto-detect all network adapters, and click Next.
For LinuxPE, do not select any drivers, just click Next.

• On the Create Automation Boot Disk step, when creating a WinPE Bootable ISO CD Image, select
Boot Windows PE into RAM disk.

• When creating USB keys, select Detect as last disk.
• When using USB keys for Integrity target servers, after the USB key has been created, insert the key

into the target server, and create an EFI boot entry for it using the name 'Altiris Automation'.
Other considerations when using boot media:

• If a job uses multiple automation environments, on the target server, you must swap automation boot
media at the appropriate time during the execution of the job.

• After an upgrade, you must re-create all of your boot media to pick up the latest HP support.
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